Is my DIGIPASS 905 for eID supported on Mac OS X 10.9 Mavericks?

Type:
FAQ FAQ (# 990081)
Date Added:
January 20, 2014

Question

Is my DIGIPASS 905 for eID supported on Mac OS X 10.9 Mavericks?

Answer

Cause

In Mac OS X 10.9 (OS X Mavericks), the DIGIPASS 905 card reader is not always recognized by the operating system.  

How can you see your DIGIPASS 905 is not recognized?


How can you see your DIGIPASS 905 is not recognized?

After opening the eID Viewer (issued by the Federal Government), the above icon will be shown, indicating that the reader is not recognized by the operating system.
Note that it is possible that the power lights of the DIGIPASS 905 are on, but that the device is not able to read your eID card.

Workaround
  1. Disconnect the card reader and (re)start your Mac.
  2. Insert your eID card into the DIGIPASS 905 card reader.
  3. Once your Mac has started up, connect the DIGIPASS 905 card reader (with your eID card already inserted) to your Mac.
  4. Finally, start up the eID Viewer or go to “My Minfin” (Tax-On-Web) and other applications.
Technical background
  1. Certain older versions of the DIGIPASS 905 card reader are not recognized by OS X when connected during startup. This can be solved by connecting the reader after booting.
  2. Smart card applications are dependent on an OS service for interacting with the connected readers. By design, this service is only started by OS X when a DIGIPASS 905 card reader is connected to the system. This means any application (such as the eID Viewer) trying to access the service before a reader is connected, will receive an error. This can be solved by starting (or restarting) the smart card application after connecting the reader.
Which version of DIGIPASS 905 card reader do you have?

You can check the version of your DIGIPASS 905 card reader through the Apple System Information. Click on the Apple icon in the top left corner. Then, click on ‘About this Mac’ and look for the button ‘More Info’.  Further, look for ‘System Report’ and go to ‘USB’.
On the right side of the screen, you will see your version of the DIGIPASS 905.


On the right side of the screen, you will see your version of the DIGIPASS 905

What’s next?

2 different versions of DIGIPASS 905 are in circulation: version 1.1 and 2.0.
If you have version 1.1, please check the section ‘How can you replace your DIGIPASS 905?’
If you have version 2.0, please follow these next steps:

  1. Connect the reader with the eID card already inserted.
  2. Start a Terminal Session.
  3. Type ‘pcsctest’ and hit enter.

The output that appears on your screen should look like the following:


The output that appears on your screen should look like the following

The ATR value of your eID card should appear in the area marked with the black rectangle. If a value is shown, this means the reader itself is not defective.
If the DIGIPASS 905 still does not work, then the problem is located on the plugin/software. Please contact your software provider for more information.
If the ATR value is not shown, it means the reader does not work properly.
See below on how to request a DIGIPASS replacement.

How can you replace your DIGIPASS 905?

If you want to replace your DIGIPASS 905, please request a Return Merchandise Authorization (RMA).
Go to the following link: https://shop.vasco.com/rma_form.aspx and complete the form.
Under ‘Order Reference’, you can fill in ‘20140101T000000RET’, in case you did not buy your DIGIPASS 905 on http://shop.vasco.com.
Once your completed form has arrived at our Quality Control department, the newest version of DIGIPASS 905 will be sent to you. 

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